System Performance
Incident Report for Spireon
Postmortem

An incident occurred on Tuesday, March 2 during a planned upgrade to two Spireon’s MongoDB Database systems, which caused an impact to Spireon enterprise customers.  The maintenance was tested and validated in a non production environment the week prior. The issue was related to a query that inserted an incorrect character that was not recognized by the system. The Spireon team followed rolled back procedures and resolved the character case sensitive item, and continued with a successful upgrade of the two database systems. The incident was resolved in about 90 minutes. We sincerely apologize for the disruption of service.

Posted Mar 10, 2021 - 10:18 PST

Resolved
This incident has been resolved.
Posted Mar 02, 2021 - 23:00 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2021 - 21:26 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 02, 2021 - 21:18 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2021 - 21:13 PST
Update
We are continuing to work on a fix for this issue.
Posted Mar 02, 2021 - 20:44 PST
Identified
A planned maintenance with no expected impact has gone awry. The engineering team has identified the issue and is working diligently on resolving the issue. API services are impacted at the moment
Posted Mar 02, 2021 - 20:43 PST
Update
We are continuing to investigate this issue.
Posted Mar 02, 2021 - 19:45 PST
Investigating
We are currently investigating the issue.
Posted Mar 02, 2021 - 19:01 PST
This incident affected: Carrier / Device Communication.