Application Performance Degredation
Incident Report for Spireon
Resolved
This incident has been resolved.
Posted Mar 30, 2023 - 17:53 PDT
Investigating
We are currently investigating this issue.
Posted Mar 30, 2023 - 17:16 PDT
This incident affected: Websites / Applications (FleetLocate Fleet, FleetLocate Transportation, LoJack, GoldStar) and Carrier / Device Communication.