Google Maps Platform services are experiencing high rates of error
Incident Report for Spireon
Resolved
Google confirmed that the incident is resolved.
Posted Mar 18, 2022 - 12:36 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 18, 2022 - 10:46 PDT
Investigating
Multiple Google Maps Platform services are experiencing high rates of error. Users may experience degraded performance or failure when viewing map related data and images.
Posted Mar 18, 2022 - 10:46 PDT
This incident affected: Websites / Applications (FleetLocate Fleet, FleetLocate Transportation, LoJack).